import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\+)?(1)?([-(.])?([1-9]\\d{2})([-).])?\\s?([1-9]\\d{2})([-.])?(\\d{4})|([1-9]\\d{2})([-.])?([1-9]\\d{2})([-.])?(\\d{4})|([1-9]\\d{2})([-.])?(\\d{4}))";
final String string = "1-800-555-1212\n\n"
+ "+1-800-555-1212\n\n"
+ "1(800)555-1212\n\n"
+ "800-555-1212\n\n"
+ "800.555.1212\n\n"
+ "555-1212\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}