// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(\+)?(1)?([-(.])?([1-9]\d{2})([-).])?\s?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?(\d{4}))").unwrap();
let string = "1-800-555-1212
+1-800-555-1212
1(800)555-1212
800-555-1212
800.555.1212
555-1212
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}