import re
regex = re.compile(r"(?:(\+)?(1)?([-(.])?([1-9]\d{2})([-).])?\s?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?(\d{4}))", flags=re.MULTILINE)
test_str = ("1-800-555-1212\n\n"
"+1-800-555-1212\n\n"
"1(800)555-1212\n\n"
"800-555-1212\n\n"
"800.555.1212\n\n"
"555-1212\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")