re = /(?:(\+)?(1)?([-(.])?([1-9]\d{2})([-).])?\s?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?(\d{4}))/m
str = '1-800-555-1212
+1-800-555-1212
1(800)555-1212
800-555-1212
800.555.1212
555-1212
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end