#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.{5})((.*?)([0-9])(.*?)([0-9])(.*)|(.{11})(.)(.)(.*))(.{5})$"
Local $sString = "h8lcmrhh2m9vq4gkogvlokf4k2" & @CRLF & _
"" & @CRLF & _
"abcde12345fghij67890" & @CRLF & _
"1a2b3c4d5e6f7g8h9i0j1k2l3m" & @CRLF & _
"34gf7asjkabaa4sfdlencxnkil9qrx"
Local $sSubst = "$1$3$6$5$4$7$8$10$9$11$12"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)