use strict;
my $str = 'h8lcmrhh2m9vq4gkogvlokf4k2
abcde12345fghij67890
1a2b3c4d5e6f7g8h9i0j1k2l3m
34gf7asjkabaa4sfdlencxnkil9qrx';
my $regex = qr/^(.{5})((.*?)([0-9])(.*?)([0-9])(.*)|(.{11})(.)(.)(.*))(.{5})$/mp;
my $subst = '$1$3$6$5$4$7$8$10$9$11$12';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";