const regex = /^(.{5})((.*?)([0-9])(.*?)([0-9])(.*)|(.{11})(.)(.)(.*))(.{5})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{5})((.*?)([0-9])(.*?)([0-9])(.*)|(.{11})(.)(.)(.*))(.{5})$', 'gm')
const str = `h8lcmrhh2m9vq4gkogvlokf4k2
abcde12345fghij67890
1a2b3c4d5e6f7g8h9i0j1k2l3m
34gf7asjkabaa4sfdlencxnkil9qrx`;
const subst = `$1$3$6$5$4$7$8$10$9$11$12`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);