#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\\)[^\\]*\\[^\\]*$"
Local $sString = "D:\Archive Directory\2015-12-31 PM\SerialNo_01" & @CRLF & _
"D:\Archive Directory\2016-01-01\SerialNo_02" & @CRLF & _
"D:\Archive Directory\January 2016\SerialNo_03"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")