const regex = /(?<=\\)[^\\]*\\[^\\]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\\)[^\\\\]*\\\\[^\\\\]*$', 'gm')
const str = `D:\\Archive Directory\\2015-12-31 PM\\SerialNo_01
D:\\Archive Directory\\2016-01-01\\SerialNo_02
D:\\Archive Directory\\January 2016\\SerialNo_03`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}