$re = '/(?<=\\\\)[^\\\\]*\\\\[^\\\\]*$/m';
$str = 'D:\\Archive Directory\\2015-12-31 PM\\SerialNo_01
D:\\Archive Directory\\2016-01-01\\SerialNo_02
D:\\Archive Directory\\January 2016\\SerialNo_03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);