import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\\)[^\\\\]*\\\\[^\\\\]*$";
final String string = "D:\\Archive Directory\\2015-12-31 PM\\SerialNo_01\n"
+ "D:\\Archive Directory\\2016-01-01\\SerialNo_02\n"
+ "D:\\Archive Directory\\January 2016\\SerialNo_03";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}