#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s).*?id="(.*?)".*?time">(.*?)<\/.*?subject">\[(.*?)\].*?|.*$"
Local $sString = "<div class="list" id="1">" & @CRLF & _
" <div class="time">12:01 PM</div>" & @CRLF & _
" <div class="subject">[This is dummy Subject1] This is some dummy strings after subject</div>" & @CRLF & _
"<div/>" & @CRLF & _
"<div class="list" id="2">" & @CRLF & _
" <div class="time">12:01 PM</div>" & @CRLF & _
" <div class="subject">[This is dummy Subject2] This is some dummy strings after subject</div>" & @CRLF & _
"<div/>" & @CRLF & _
"<div class="list" id="3">" & @CRLF & _
" <div class="time">12:01 PM</div>" & @CRLF & _
" <div class="subject">[This is dummy Subject3] This is some dummy strings after subject</div>" & @CRLF & _
"<div/>"
Local $sSubst = "$1|$2|$3\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)