// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s).*?id="(.*?)".*?time">(.*?)<\/.*?subject">\[(.*?)\].*?|.*$"#).unwrap();
let string = "<div class=\"list\" id=\"1\">
<div class=\"time\">12:01 PM</div>
<div class=\"subject\">[This is dummy Subject1] This is some dummy strings after subject</div>
<div/>
<div class=\"list\" id=\"2\">
<div class=\"time\">12:01 PM</div>
<div class=\"subject\">[This is dummy Subject2] This is some dummy strings after subject</div>
<div/>
<div class=\"list\" id=\"3\">
<div class=\"time\">12:01 PM</div>
<div class=\"subject\">[This is dummy Subject3] This is some dummy strings after subject</div>
<div/>";
let substitution = "$1|$2|$3\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}