import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?id=\"(.*?)\".*?time\">(.*?)<\\/.*?subject\">\\[(.*?)\\].*?|.*$";
final String string = "<div class=\"list\" id=\"1\">\n"
+ " <div class=\"time\">12:01 PM</div>\n"
+ " <div class=\"subject\">[This is dummy Subject1] This is some dummy strings after subject</div>\n"
+ "<div/>\n"
+ "<div class=\"list\" id=\"2\">\n"
+ " <div class=\"time\">12:01 PM</div>\n"
+ " <div class=\"subject\">[This is dummy Subject2] This is some dummy strings after subject</div>\n"
+ "<div/>\n"
+ "<div class=\"list\" id=\"3\">\n"
+ " <div class=\"time\">12:01 PM</div>\n"
+ " <div class=\"subject\">[This is dummy Subject3] This is some dummy strings after subject</div>\n"
+ "<div/>";
final String subst = "$1|$2|$3\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}