$re = '/.*?id="(.*?)".*?time">(.*?)<\/.*?subject">\[(.*?)\].*?|.*$/s';
$str = '<div class="list" id="1">
<div class="time">12:01 PM</div>
<div class="subject">[This is dummy Subject1] This is some dummy strings after subject</div>
<div/>
<div class="list" id="2">
<div class="time">12:01 PM</div>
<div class="subject">[This is dummy Subject2] This is some dummy strings after subject</div>
<div/>
<div class="list" id="3">
<div class="time">12:01 PM</div>
<div class="subject">[This is dummy Subject3] This is some dummy strings after subject</div>
<div/>';
$subst = "$1|$2|$3\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;