using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?id=""(.*?)"".*?time"">(.*?)<\/.*?subject"">\[(.*?)\].*?|.*$";
string substitution = @"$1|$2|$3\n";
string input = @"<div class=""list"" id=""1"">
<div class=""time"">12:01 PM</div>
<div class=""subject"">[This is dummy Subject1] This is some dummy strings after subject</div>
<div/>
<div class=""list"" id=""2"">
<div class=""time"">12:01 PM</div>
<div class=""subject"">[This is dummy Subject2] This is some dummy strings after subject</div>
<div/>
<div class=""list"" id=""3"">
<div class=""time"">12:01 PM</div>
<div class=""subject"">[This is dummy Subject3] This is some dummy strings after subject</div>
<div/>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}