#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+)(\-?\d.*)$"
Local $sString = "94324.13%" & @CRLF & _
"007007.13%" & @CRLF & _
"0354202.91%" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1|\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)