re = /^(\d+)(\-?\d.*)$/m
str = '94324.13%
007007.13%
0354202.91%
'
subst = '\\1|\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result