$re = '/^(\d+)(\-?\d.*)$/m';
$str = '94324.13%
007007.13%
0354202.91%
';
$subst = "\1|\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;