const regex = /^(\d+)(\-?\d.*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)(\\-?\\d.*)$', 'mg')
const str = `94324.13%
007007.13%
0354202.91%
`;
const subst = `\1|\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);