using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)(\-?\d.*)$";
string substitution = @"\1|\2";
string input = @"94324.13%
007007.13%
0354202.91%
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}