using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE) # Definitions
(?P<tags>user|time|sport|something) # Keys
(?P<value>[^=&]+) # Value
(?P<pair>(?&tags)(?:=(?&value))?) # A pair could have an optional value
(?P<query>(?&pair)(?:&(?&pair))*) # A query is one or more pairs separated with &
)
(?&query) # Match it";
string input = @"Log 1: user=mike&time=now&sport=hockey&something
Log 2: time=now&sport=hockey&user=mike&something
Log 3: sport=hockey&time=now&user=mike&something";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}