import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE) # Definitions\n"
+ " (?P<tags>user|time|sport|something) # Keys\n"
+ " (?P<value>[^=&]+) # Value\n"
+ " (?P<pair>(?&tags)(?:=(?&value))?) # A pair could have an optional value\n"
+ " (?P<query>(?&pair)(?:&(?&pair))*) # A query is one or more pairs separated with &\n"
+ ")\n"
+ "(?&query) # Match it";
final String string = "Log 1: user=mike&time=now&sport=hockey&something\n\n"
+ "Log 2: time=now&sport=hockey&user=mike&something\n\n"
+ "Log 3: sport=hockey&time=now&user=mike&something";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}