re = /(?(DEFINE) # Definitions
(?P<tags>user|time|sport|something) # Keys
(?P<value>[^=&]+) # Value
(?P<pair>(?&tags)(?:=(?&value))?) # A pair could have an optional value
(?P<query>(?&pair)(?:&(?&pair))*) # A query is one or more pairs separated with &
)
(?&query) # Match it/x
str = 'Log 1: user=mike&time=now&sport=hockey&something
Log 2: time=now&sport=hockey&user=mike&something
Log 3: sport=hockey&time=now&user=mike&something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end