// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?(DEFINE) # Definitions
(?P<tags>user|time|sport|something) # Keys
(?P<value>[^=&]+) # Value
(?P<pair>(?&tags)(?:=(?&value))?) # A pair could have an optional value
(?P<query>(?&pair)(?:&(?&pair))*) # A query is one or more pairs separated with &
)
(?&query) # Match it").unwrap();
let string = "Log 1: user=mike&time=now&sport=hockey&something
Log 2: time=now&sport=hockey&user=mike&something
Log 3: sport=hockey&time=now&user=mike&something";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}