$re = '/(?(DEFINE) # Definitions
(?P<tags>user|time|sport|something) # Keys
(?P<value>[^=&]+) # Value
(?P<pair>(?&tags)(?:=(?&value))?) # A pair could have an optional value
(?P<query>(?&pair)(?:&(?&pair))*) # A query is one or more pairs separated with &
)
(?&query) # Match it/x';
$str = 'Log 1: user=mike&time=now&sport=hockey&something
Log 2: time=now&sport=hockey&user=mike&something
Log 3: sport=hockey&time=now&user=mike&something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);