# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?mi)^\d+.+\d{4}-\d{2}-\d{2},\h+\d{1,2}:\d{1,2}:\d{1,2}\h+(.+)/\1/gu;t' <<< "10 Highlight 2020-11-20, 21:48:47 Lorem ipsum Case 1...
90 Highlight 2020-11-20, 21:35:17 Lorem ipsum Case 2...
2 Highlight John Smith 2020-11-20, 17:19:26 Lorem ipsum Case 3..."