$re = '/(?mi)^\d+.+\d{4}-\d{2}-\d{2},\h+\d{1,2}:\d{1,2}:\d{1,2}\h+(.+)/u';
$str = '10 Highlight 2020-11-20, 21:48:47 Lorem ipsum Case 1...
90 Highlight 2020-11-20, 21:35:17 Lorem ipsum Case 2...
2 Highlight John Smith 2020-11-20, 17:19:26 Lorem ipsum Case 3...';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;