#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(?mi)^\d+.+\d{4}-\d{2}-\d{2},\h+\d{1,2}:\d{1,2}:\d{1,2}\h+(.+)"
Local $sString = "10 Highlight 2020-11-20, 21:48:47 Lorem ipsum Case 1..." & @CRLF & _
"90 Highlight 2020-11-20, 21:35:17 Lorem ipsum Case 2..." & @CRLF & _
"2 Highlight John Smith 2020-11-20, 17:19:26 Lorem ipsum Case 3..."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)