const regex = /(?mi)^\d+.+\d{4}-\d{2}-\d{2},\h+\d{1,2}:\d{1,2}:\d{1,2}\h+(.+)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?mi)^\\d+.+\\d{4}-\\d{2}-\\d{2},\\h+\\d{1,2}:\\d{1,2}:\\d{1,2}\\h+(.+)', 'gu')
const str = `10 Highlight 2020-11-20, 21:48:47 Lorem ipsum Case 1...
90 Highlight 2020-11-20, 21:35:17 Lorem ipsum Case 2...
2 Highlight John Smith 2020-11-20, 17:19:26 Lorem ipsum Case 3...`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);