import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mi)^\\d+.+\\d{4}-\\d{2}-\\d{2},\\h+\\d{1,2}:\\d{1,2}:\\d{1,2}\\h+(.+)";
final String string = "10 Highlight 2020-11-20, 21:48:47 Lorem ipsum Case 1...\n"
+ "90 Highlight 2020-11-20, 21:35:17 Lorem ipsum Case 2...\n"
+ "2 Highlight John Smith 2020-11-20, 17:19:26 Lorem ipsum Case 3...";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}