# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^#(\w+)#$/<h1>\1<\/h1>/gm;t' <<< "#Title1#
##title2##"