use strict;
my $str = '#Title1#
##title2##';
my $regex = qr/^#(\w+)#$/mp;
my $subst = '<h1>\\1</h1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";