#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^#(\w+)#$"
Local $sString = "#Title1#" & @CRLF & _
"##title2##"
Local $sSubst = "<h1>\1</h1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)