const regex = new RegExp('^#(\\w+)#$', 'gm')
const str = `#Title1#
##title2##`;
const subst = `<h1>\1</h1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);