$re = '/^#(\w+)#$/m';
$str = '#Title1#
##title2##';
$subst = "<h1>\1</h1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;