const regex = /(<\/span> )(span)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/span> )(span)', 'gm')
const str = `test1 test2 tes<span style="color:red;">t3</span> span test4`;
const subst = `$1<span>$2</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);