import Foundation
let pattern = #"(<\/span> )(span)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"test1 test2 tes<span style="color:red;">t3</span> span test4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<span>$2</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)