$re = '/(<\/span> )(span)/m';
$str = 'test1 test2 tes<span style="color:red;">t3</span> span test4';
$subst = "$1<span>$2</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;