// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<\/span> )(span)").unwrap();
let string = "test1 test2 tes<span style=\"color:red;\">t3</span> span test4";
let substitution = "$1<span>$2</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}