# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(.{10,})\s*(?:\1)+/\1/g;t' <<< "I would like this
text to be
reduced
I would like this
text to be
reduced"