import Foundation
let pattern = #"(?s)(.{10,})\s*(?:\1)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I would like this
text to be
reduced
I would like this
text to be
reduced
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)