import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(.{10,})\\s*(?:\\1)+";
final String string = "I would like this\n"
+ "text to be\n\n"
+ "reduced\n"
+ "I would like this\n"
+ "text to be\n\n"
+ "reduced";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}