re = /(?s)(.{10,})\s*(?:\1)+/
str = 'I would like this
text to be
reduced
I would like this
text to be
reduced'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result