# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\(?![A-Za-z])\s*//gm;t' <<< "hello \+ \\\world \+ \\\\ this \234 \ is \pattern\"