use strict;
my $str = 'hello \\+ \\\\\\world \\+ \\\\\\\\ this \\234 \\ is \\pattern\\';
my $regex = qr/\\(?![A-Za-z])\s*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";