const regex = new RegExp('\\\\(?![A-Za-z])\\s*', 'gm')
const str = `hello \\+ \\\\\\world \\+ \\\\\\\\ this \\234 \\ is \\pattern\\`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);