re = /\\(?![A-Za-z])\s*/m
str = 'hello \\+ \\\\\\world \\+ \\\\\\\\ this \\234 \\ is \\pattern\\'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result