$re = '/\\\\(?![A-Za-z])\s*/m';
$str = 'hello \\+ \\\\\\world \\+ \\\\\\\\ this \\234 \\ is \\pattern\\';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;