using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"k[.-]?d[.-]?f[.-]?8[.-]?2[.-]?1[.-]?0";
string input = @"kdf.8210, kdf-8210, kdf.82-10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}